Problems attempting to upload to community songbook

This topic is listed in Website Problems & Help. It has been viewed 144 times and 3 replies have been made.

Rabid_ParrotLEVEL 78

Edited post by Rabid_ParrotGOLD

I'm here! maybe...


Recently I haven't been able to upload songs to the community songbook. I select the file and type in all the information (name, band, year, genre) and the "next" button is greyed out. Is there a reason for this?

I've tried Edge, Chrome and Opera with the same result.

Oh, I am running an up to date version of Windows 10. All drivers and flash up to date

RichAllenLEVEL 75

Reply by RichAllenGOLD

Contact SingSnapSupport.

Michael1951LEVEL 91

Reply by Michael1951GOLD +1

There has been times that the site has been off line or having issues....but ok after a while...

Rabid_ParrotLEVEL 78

Reply by Rabid_ParrotGOLD

I'm here! maybe...

Just wanted to provide an update. Rob from support messaged me and indicated that there may be an issues when selecting the "year" while uploading.

If you leave it blank, it will proceed just fine.