Timing problems with The Mixer.

This topic is listed in Recording Help & Tips. It has been viewed 44,257 times and 433 replies have been made.

  Next >>
JasonLEVEL 48

Edited post by Jason

If you are having issues with the 'sync' then this thread is for you.

What I mean by 'sync' is the synchronization of the voice to the music. If this is confusing to you, let me explain some basics. You'll need to understand what's happening and how to fix it.

When you record, you are making an audio track that I'll call the VOICE track. If you have recorded something, then un-check the "Enable Music" in the mixer, what you will hear is only the Voice track.

When you Enable Music in The Mixer, you hear a second track, called the MUSIC track along with the VOICE track. The MUSIC track is simply the same music you heard when you recorded. It is being played back a second time.

You can think of it as a tape recorder (VOICE track) and a CD (MUSIC track). When Enable Music is checked, The Mixer is playing the CD and the tape back at the same time.

Now, imagine you pressed "play" on a tape and a CD at the same time. What if you pressed play a fraction of a second late on the tape? Well, then the VOICE track would play slightly behind the MUSIC track. It could go the other way too, with the MUSIC behind the VOICE.

Starting to make sense, huh?

Now, to correct this, you use the "Adjust Timing" function in The Mixer. This delays or advances the VOICE track so that the two tracks sound aligned, or synchronized. On many computers, you don't need to adjust this, but there may be times you might have to. Other computers requires an adjustment everytime. I have one PC at home that always requires +2 on the adjuster. It's just the way that computer is.

Sometimes, the 'sync' CANNOT BE CORRECTED with the timing tool.

Sometimes, when you are recording, the VOICE track suffers small 'dropouts', where a tiny part of the recording goes missing. You can replicate this by opening another program or web page while recording. What it happening is The Recorder doesn't get enough of your computer's time, and just doesn't record a few moments of the sound.

With "Enable Music" unchecked, you'd probably never hear this. But when you check "Enable Music", you will hear both the VOICE and the MUSIC side by side. Since your VOICE track is missing some small parts, the track will actually be shorter than the MUSIC track.

So, at the beginning of the song the sync might be OK, but as the song goes on (and as the dropouts occur) the sync will gradually get worse and worse. Unfortunately at this time there is nothing that can be done about this. You'll have to try recording this song again.

Here's what you can do to help prevent this.

Most of the time, this can be stopped by closing all the unnecessary programs that are running on your computer. Obviously, it's easy to close all the programs in the bottom bar, but did you know that for every icon in the System Tray (by the clock) there is a program running too? So if you have a lot of icons down there, you have a lot of programs running. You can right click on each icon and see if an Exit option exists.

You shouldn't need to close your antivirus or firewall software, but you can try to close them for troubleshooting purposes.

Once all the unnecessary programs are closed, close your browser and reopen it. In one single window and tab, go to SingSnap.com and try to record a song again.

Another culprit could be a program that loads when your webcam is in use. WebCam Max, ManyCam, or the tools that come with Logitech cams can all take a LOT of computer time away from The Recorder.

Here is something to consider: I have a Pentium 3 1.2GHz laptop at home. I can't even view youtube videos without it 'chopping' because it's too slow; but without a webcam, I can use The Recorder and Mixer just fine, in Stereo too!

Finally, if The Mixer will just not work for you, or you just don't care to get this involved, you can always un-check "Enable Music". With that un-checked, there is no MUSIC track to sync; therefore, no sync issues. It will work just like the old system. But, you might have to change your sound card to record the music like you used to (stereo mix).

I hope this helps!

If you're still having trouble after trying the tips above you can send a private message to SingSnapSupport for more assistance.

LeslieLEVEL 62

Reply by LeslieGOLD +1

OK...I'll be the first to bite lol. Here is my sync issue lol

I have recorded one song. Yes I know such a huge number lol. I played with it and got the timing right. I was so excited. Loved that I didn't have to record over and over again to get volumes right too lol. I had it just how I wanted it. I was excited and clicked save!

After it finally got done saving I went to listen to the finished product. It was no longer in sync. My voice was faster than the music. How did that happen? Did I do something wrong?

CanadaBlonde

Reply by CanadaBlondeGOLD

I have also been having timing issues as janie describes above for at the past several days, and tonight as well. Timing way off in preview so having to adjust sometimes up to -10 or -11 and then the final product being completely out of sync. A few songs today I tried at least 1/2 dozen times before I could get them to sync up

However, this gives me a good place to start in trying to sort this out. Two things I keep forgetting about are Outlook and Skype, I'll see what happens when I try to record after closing those.

Thanks, Jason, it makes some sense now

FleaCDPLEVEL 9

Edited reply by FleaCDP

Jason - i've never been able to sync up any songs I've tried in stereo. The statement you made above:

So, at the beginning of the song the sync might be OK, but as the song goes on (and as the dropouts occur) the sync will gradually get worse and worse. Unfortunately at this time there is nothing that can be done about this. You'll have to try recording this song again.

Happens to me every time -- does that mean I will never be able to use stereo?

JasonLEVEL 48

Reply by Jason

Can you ladies both PM me some examples of this, that I can use to work towards a solution?

Also, I will be working on a 'remix' tool that will allow Gold members to go back and try the mix again if it didn't save right the first time.

However, it sounds like the preview system / preview page doesn't work at all for you two. I'm not totally surprised, as I partially expected a few problems like this, but if I can get some examples I can perhaps correct.

Do either of you have issues with the Preview Accuracy light being red or yellow a lot, or when it turns green does it stay pretty much?

Also, what operating system, browser and version of Flash do you have?

Go here to find out your version of Flash:
http://www.macromedia.com/software/flash/about/

Cheers!

JasonLEVEL 48

Reply by Jason

FleaCDP, it does pose a real threat. I have yet to find a machine that I can replicate this problem on reliably. Can you PM me detailed information about your machine, similar to what I asked in the last post? No detail too small.

CanadaBlonde

Reply by CanadaBlondeGOLD

Oops! I just deleted a bunch before I read this, I'll check and see if I saved any and PM them to you. I don't remember my Preview Indicator ever staying green, it usually keeps changing from one color to another and I only make an adjustment when it's on green. Oh, a remix tool would be great! would have saved doing the same songs over and over again; I think I was started to sound angry in them at the last..... lol!

I have Windows XP Home Edition, just updated my Flash Player to the newest version (9,0,124,0) and have been using Firefox as a browser (as IE was giving me problems).

Thanks! hope this helps!

JasonLEVEL 48

Reply by Jason

FLEA: this one sounds great:

http://www.singsnap.com/snap/r/c11233bd3

Are you talking about the audio or the video sync?

DaveGLEVEL 9

Reply by DaveG

Jason, a personal thanks for all your effort and hard work.

Today, a few sync problems with the mixer though. Vocals sounded ok through preview and were in sync.

Once saved, vocals are with back tracking vocals, yet the music seems to be too slow. Maybe a server issue? This was on the Hush(Deep Purple) song.

http://www.singsnap.com/snap/r/c511d1a7b

starchickyLEVEL 27

Edited reply by starchickyGOLD

Ok, I recorded about 562 million songs tonight, and for me, I have found that when I listen to the recording, the timing is off, so I get it all set right, and then when I save it, the timing is off! ARGH!!! BUT, I noticed that the timing was off in the opposite directions from the preview. In the preview, my voice was ahead, in the finished song, my voice was behind, so I recorded one, and didn't change the synch at all, and just saved it, and......it worked. Who knows? (besides our wonderful, fantastic, mighty fine tech guys) Maybe this will help someone else tonight. Oh, and I didn't REALLY record that many songs, I was just kidding. LOL

Bubba1LEVEL 26

Reply by Bubba1

If you have problems and need help feel free to stop by the chat room and log into teh tech support chat room. Or pm me.

Chat room lnk

http://www.singsnap.com/snap/chat/index

Jim

FleaCDPLEVEL 9

Reply by FleaCDP

FLEA: this one sounds great:

http://www.singsnap.com/snap/r/c11233bd3

Are you talking about the audio or the video sync?jason

The one you linked above was not recorded in stereo.

This one was:

http://www.singsnap.com/snap/r/c512d7283

Note how the timing is ok at first, but then gradually gets worse throughout the song.

texastwistrLEVEL 16

Reply by texastwistrGOLD

I tried recording,sounded great,when I go to listen to recording ,music and voice are off.tried to set music with vocals.didnt work

uniqartistLEVEL 37

Reply by uniqartistGOLD

I had the exact same problem last night with the timing thing. I adjusted everything in the preview to my liking. I adjusted the timing to -2 or 3, and I waited for the accuracy light to turn green before each adjustment. I then played the preview all the way through twice to ensure all the setting sounded the way I wanted them to. I then saved it and posted the link in a contest I was recording the song for. It's a good thing I always check my links to make sure they work or are correct, because when I played the link the timing was off. Seems to me it may have been almost exactly off as much as I had to adjust it in the preview.

I'm running Windows XP, not a terribly new computer, but seems to run just fine. My Flash is version 9,0,124,0 (not sure if it's most recent). My browser is Mozilla FireFox, as I have also had problems with IE in the past.

I always close all other programs when recording, but I haven't tried closing out the icons in my system tray. There aren't that many anyway. However, I am using a Veo Stingray Webcam with my recording, maybe that might effect it. Haven't had any issues prior to this, hope we can all get this to work, seems like a great feature, thank you!

If you want me to PM the link to the recording, I don't think I deleted it yet, but it's not public. Let me know.

uniqartistLEVEL 37

Reply by uniqartistGOLD

Like I haven't said enough...lol...in listening to my recording again it almost sounds to me that my vocals have been sped up a bit. Maybe it just seems to sound that way because timing is off...

DarcyDoo

Edited reply by DarcyDooGOLD

I have closed all my programs, etc. My song typically sounds fine at the beginning, but toward the end of the song it gets really off.

I have windows XP, have the newest version of Flash Player, and I am using Firefox. I have cleared my cache, shut down all other programs, etc., and the sync still gets off at the end of the song. It seems to be worse if I use my webcam.

It is super frustrating!!!

Bluegrass308LEVEL 3

Reply by Bluegrass308GOLD

Is it possible to harmonize in stereo ?? I tried one and my two voices just didn't stay together..............

JasonLEVEL 48

Reply by Jason

Is it possible to harmonize in stereo ?? I tried one and my two voices just didn't stay together..............Bluegrass308

For sure, in fact it typical works better than non-harmony / duet.

Here's a good example:

http://www.singsnap.com/snap/r/b71226282

Jason

JasonLEVEL 48

Reply by Jason

I have closed all my programs, etc. My song typically sounds fine at the beginning, but toward the end of the song it gets really off.

I have windows XP, have the newest version of Flash Player, and I am using Firefox. I have cleared my cache, shut down all other programs, etc., and the sync still gets off at the end of the song. It seems to be worse if I use my webcam.

It is super frustrating!!!DarcyDoo

I totally understand your frustration. The key is finding that one element that is causing the recording to 'break up' which is why the sync doesn't work.

You might want to try Google Chrome and see if it helps.

CanadaBlonde

Edited reply by CanadaBlondeGOLD

Just wanted to say, I am having MUCH better luck with sync when assuring that the song is completely loaded before clicking record, thanks to your suggestion Jason.

Have tried 3 or 4.... every one has synced up perfectly! Woohoo!!!! (a few needed adjustments in Preview). Hopefully that's a large piece of this puzzle......

WildAngelOne

Edited reply by WildAngelOne

Same problem here I tried several times, the timing was perfect in the preview after adjusting it, but after mixing it was totally out of sync...

Bubba1LEVEL 26

Reply by Bubba1

If you have problems and need help feel free to stop by the chat room and log into teh tech support chat room. Or pm me.

Chat room link

http://www.singsnap.com/snap/chat/index

Jim

DarcyDoo

Reply by DarcyDooGOLD

I have closed all my programs, etc. My song typically sounds fine at the beginning, but toward the end of the song it gets really off.

I have windows XP, have the newest version of Flash Player, and I am using Firefox. I have cleared my cache, shut down all other programs, etc., and the sync still gets off at the end of the song. It seems to be worse if I use my webcam.

It is super frustrating!!!DarcyDoo

I totally understand your frustration. The key is finding that one element that is causing the recording to 'break up' which is why the sync doesn't work.

You might want to try Google Chrome and see if it helps. jason

Well, I think I've figured it out. My firewall and my cam cannot be on when I'm recording. It just won't work. It's still not synced sometimes without those on, but the ones I've gotten to work have been without cam and without the firewall on.

What would Google Chrome do?

PaulMasonLEVEL 104

Reply by PaulMason

Ok I have noticed that any song that i have to set the timing value to + 11 or 12 always causes a error and says a email has been sent to try and solve the issue i wasnt concerned when it did it once but i have had it happen on 6 or more songs when the timing value was set to + 11 or 12 To Get The Words in sync I dont know if this is a mixer issue or if its just bad luck on my part.

uniqartistLEVEL 37

Reply by uniqartistGOLD

Yes, I too have been working on my problem. I was actually able to have a few successful recordings! Basically, I made sure all programs (that I know about) were closed, including the ones on the tool bar at the bottom of the screen. I closed and reopened the browser and then cleared my temp files from the browser just prior to recording. Generally, my goal was to have a recording that DID NOT NEED a timing adjustment on the preview. That seemed to work most of the time. Of course, I'm still trying to work on getting the vocals loud enough, but that's just an operater error I believe. Also, I was still able to use my camera, but I made sure to clear temps before each recording, or it might still be a tiny bit off on the timing. Hope this helps someone!

AnomalyLEVEL 4

Reply by Anomaly

Vocals goes out of Sync when I Enabled Music (stereo mode) There's a Stereo Delay on the Backing Music when I Adjust (vocals) the Timing.. Is this normal? or maybe I need to be a Gold Member

lily04LEVEL 77

Reply by lily04PATRON

x

CanadaBlonde

Edited reply by CanadaBlondeGOLD

I am/was a Tester and having all of the sync issues as described above. Hope I'm not making this sound simple but, as soon as I started assuring that the song was fully loaded (as suggested by Jason) before clicking the "Record" button I have been having MUCH better luck.

Haven't tried any today but the 3 or 4 I tried last evening synced up perfectly. Some needed small adjustments in Preview but playback was right on and exactly as I heard and adjusted them in Preview. (The first ones in about a week). It sometimes takes a little time for the song to load, but much less time and frustration than having to do the same song over and over again.

Hope this well help some of you. And hopefully this theory won't be all shot to h... next time I try to record...

Binky-LEVEL 8

Reply by Binky-

Vocals goes out of Sync when I Enabled Music (stereo mode) There's a Stereo Delay on the Backing Music when I Adjust (vocals) the Timing.. Is this normal? or maybe I need to be a Gold Member Anomaly

at the time i don't think stereo mode is an OPTION for blue members tho. im sure someone will inform you though

xCHELLEx

Reply by xCHELLEx

Can I just say, I cameback to singsnap yesterday and found stereo, using my aol browser the sync was totally off but when itried it thru firefox it was much easier, Im not saying its the answer but it helped me x

melLEVEL 19

Reply by melGOLD

Ok I have noticed that any song that i have to set the timing value to + 11 or 12 always causes a error and says a email has been sent to try and solve the issue i wasnt concerned when it did it once but i have had it happen on 6 or more songs when the timing value was set to + 11 or 12 To Get The Words in sync I dont know if this is a mixer issue or if its just bad luck on my part.PaulMason

Yes, NONE of the songs in which I had to adjust by +10 steps saved for me either.

melLEVEL 19

Edited reply by melGOLD

I have closed all my programs, etc. My song typically sounds fine at the beginning, but toward the end of the song it gets really off.

I have windows XP, have the newest version of Flash Player, and I am using Firefox. I have cleared my cache, shut down all other programs, etc., and the sync still gets off at the end of the song. It seems to be worse if I use my webcam.

It is super frustrating!!!DarcyDoo

I totally understand your frustration. The key is finding that one element that is causing the recording to 'break up' which is why the sync doesn't work.

You might want to try Google Chrome and see if it helps. jason

Well, I think I've figured it out. My firewall and my cam cannot be on when I'm recording. It just won't work. It's still not synced sometimes without those on, but the ones I've gotten to work have been without cam and without the firewall on.

What would Google Chrome do?DarcyDoo

I refuse to shut down my firewall since my computer was hacked. No thanks

Edit: Is Google Chrome the google browser? I tried recording with Opera and I do think that the chances are slightly better with Opera. But it could be coincidence.

Mr_MicrophoneLEVEL 52

Reply by Mr_MicrophoneGOLD

Not a big deal but an asthetic problem really...

When you change the sync of the vocal to match up, the display that moves to the vocals (non camera) goes out of sync. Even though the music sounds ok, the video window no longer matches the sound.

As I said doesn't make the recording sound bad or anything, but it's just something I noticed.

I haven't tested yet if this also goes off when the camera is used.

TracyB

Reply by TracyBGOLD

My songs will sync up but I keep getting the "There was an error mixing this song" message. Any ideas?

Bubba1LEVEL 26

Reply by Bubba1

Thanks Connieg for these great instructions. If you need tech support.

Basic instruction on getting to the stereo tech support room

Firstly click community tab and locate where it says CHAT ROOMS

click the 'CHAT ROOMS' link that you see orange above.
This will take you to the singsnap chat areas pre entry page

Click the oblong bar you see here

Once you click that a new window will appear and you will be 'connecting' and then then athenticating. Once in you will find yourself in the lobby.As on the image below when in the room you will see a scroll down slider (the one that is half cut off here lol)take it to the very bottom and you will then see another oblong tab that says
STEREO TECH SUPPORT **CLICK ON THE ORANGE ARROW** next to the room title or anywhere on that bar.

Once you click that you will see this

click 'Join' and you are in the stereo support room where a tech guy will then direct you from there.

Note you may see other rooms at different times too. But that is the room that you want for the tech guys. Hope that helps.

BABYBLUE69LEVEL 96

Reply by BABYBLUE69PATRON +5

Be safe everyone, and have a happy Memorial holiday! Love y'all xox

Most of my problems are when I'm trying to do harmony or a duet. I got my vocals in sync on this recording, but then the music sounds like a "double click."... The drums, etc, are kind of echoing....

http://www.singsnap.com/snap/r/bc1000e1d

bradleyshaneLEVEL 3

Reply by bradleyshane

just go buy a mixer from Radio Shack and stop the madness..lol

Mr_MicrophoneLEVEL 52

Reply by Mr_MicrophoneGOLD

Most of my problems are when I'm trying to do harmony or a duet. I got my vocals in sync on this recording, but then the music sounds like a "double click."... The drums, etc, are kind of echoing....

http://www.singsnap.com/snap/r/bc1000e1dclassycowgurl


Classy, thats because when you select anything other then MIC as a recording source, music is recorded along with the vocals. Then when you try to "mix" in the music there are 2 music tracks... You can successfully sync them up but it takes time to get it just right. Try using just mic as the recording source. Or if you must use what you hear, make the music bearly audible while recording. Then when mixing in the music track wait for the green light then start the music, adjsut the mixer so the music levels are fairly equal (heavy on the voice side) and start adjusting. keep restarting so you can adjust the music to match on the ramp (music before vocals) always watching to make sure you are green. when they match up and you cannot hear the echo, remix for your voice and save.

Hope that helps somewhat...

Jo_NZLEVEL 12

Reply by Jo_NZ

I have a similar thread on here talking about my timing issues....and quite frankly Im about ready to seek a new site...its not just the timer that sucks its the sound as well...what have y'all done to mono? makes my voice higher and I dont like it.....I (and Im not alone here) get the timing perfect in preview but it saves out...and each song is different, it starts out in sync but then falls out of sync halfway thru, or its so far out its crazy, or its just ever so slightly out and its so frustrating I feel like screaming....aaaaaaarrrrrgggggggghhhhhhh << whew thats better hehe

Jo_NZLEVEL 12

Reply by Jo_NZ

just go buy a mixer from Radio Shack and stop the madness..lolbradleyshane

you gonna pay for it? I cant afford a new mixer, Im a single mother trying to raise 3 kids....either that or the winning lottery numbers would also be good hehe

Mr_MicrophoneLEVEL 52

Reply by Mr_MicrophoneGOLD

From what I understand the power of your PC is a factor. I have 2G single core, and it seems even though I get the timing right in the preview, the vocals seem rushed in the playback. I tried setting the delay on the voice down one click but that sounded too delayed in the preview... I tried a song in stereo with the mixer 2 times and I sound rushed. Tried it in mono (just in case it was me) and it sounded fine.

Mixer needs work still I think. I'm little dissapointed, cause I really prefer the stereo music track. But it is what it is. Keep working on it guys... I'm a bit of a perfectionist and its real close, but it really stands out to me. I have left a few songs up in mono and stereo for comparison. Let me know what you think. I think it sounds like I am leading the music in parts, in the stereo versions but am spot on in the mono versions.

For now I will go back to mono...

Here are my specs AthlonXP 2600, 1GB fast Ram DDR but single channel. Audigy2 ZS, Windows XP home. All current audio drivers, current IE, Current Flash player. Sata HD. I get green on the sync, no unneeded background proggys running.

If you need help troubleshooting (staff and admin) or testing feel free to contact me. I am willing to help!

RainnaraLEVEL 67

Reply by Rainnara

Oh yea....I get it now.......Thank you!!!.......:-)

Lightwalker

Reply by Lightwalker

Sometimes when my songs begin to take a long time to save I just exit IE and then start all over and this most always helps. You should clean out your cookies and other items often in the tools section of your toolbar and this helps also. Click tools and then internet options and you'll see where you can delete them.

Lightwalker

Reply by Lightwalker

just go buy a mixer from Radio Shack and stop the madness..lolbradleyshane

you gonna pay for it? I cant afford a new mixer, Im a single mother trying to raise 3 kids....either that or the winning lottery numbers would also be good heheJo_NZ

For less than &50.00 I ordered a Behringer MINI FEX 800 ULTRA COMPACT 24-BIT STEREO MULTI-FX PROCESSOR online and delivered to my door. I really like it and I thought that was a bargain! Just go to beheringer.com.

Diana38LEVEL 17

Reply by Diana38GOLD

I have timing issues to like the rest but I think I will get it eventually. I have only done one song.

I have a suggestion do you think you can fix it so we can edit a song and fix the timing on the song, now that it's in stereo.

FuffyPhilLEVEL 100

Reply by FuffyPhilGOLD

I don't have any idea where to go with this, so I'll just address it here.
Is it possible to sync our video with the stereo audio!? I just can't figure out how to do it, so until it's possible, or until I can get it figured out, I've decided not to do video with stereo.
Is strange though, as one of my brothers can do it~ *smile*

Deelyght

Reply by DeelyghtGOLD

I can't do video either...and I used to be able to...also..the music sounds better but for me the voice sounds muffled now....please keep working on it!!! thank you!

lovesfairytales

Reply by lovesfairytales

SO, IF WE CAN HEAR MUSIC AND OUR VOICE WE DONT HAVE TO USE THE MIXER AT ALL? BUT IS THE QUALITY OF THE RECORDING GONNA BE THE SAME AS WHEN 'THE MIXER' IS USED? WHAT WILL BE THE DIFFERENCE?

lovesfairytales

Reply by lovesfairytales

IM IN THE WRONG FORUM. SORRY

Jo_NZLEVEL 12

Reply by Jo_NZ

just go buy a mixer from Radio Shack and stop the madness..lolbradleyshane

you gonna pay for it? I cant afford a new mixer, Im a single mother trying to raise 3 kids....either that or the winning lottery numbers would also be good heheJo_NZ

For less than &50.00 I ordered a Behringer MINI FEX 800 ULTRA COMPACT 24-BIT STEREO MULTI-FX PROCESSOR online and delivered to my door. I really like it and I thought that was a bargain! Just go to beheringer.com.Lightwalker

dude...can I borrow $50 hehe

ELVIS_USALEVEL 67

Reply by ELVIS_USAGOLD

hay jason has there been any fix so i can record with my mic port pro and not sound like a chipmunk...lol i real thought usb might be cool to try i went back to my old way without usb and i record fine i still woud like to try it on singsnap one day this usb unit...

  Next >>