SS Security Status in Browser

This topic is listed in Website Problems & Help. It has been viewed 279 times and 11 replies have been made.

SunshineLEVEL 93

Post by SunshineGOLD

Why is the browser URL for Singsnap showing "Not Secure" once again? Is there something I need to do on my end. It reflects "Not Secure" or "http" whether I am using Chrome or Microsoft Edge!

Thank you....

starfire411LEVEL 94

Reply by starfire411 +5

chrome was hacked from what I understand, my grandkids and their schools are not able to use their chrome books right now due to the problem
Edge should not have it though

BCSchmerker2LEVEL 87

Edited reply by BCSchmerker2

As of 11 September 2018 only Payments and Recording are secured. I actually had a Website Suggestions Topic "Upgrade entire Site to TLS 1.2" back in 2016, as SingSnapĀ® is just as vulnerable to MitM attacks on public pages as any other Web service not using Transport Layer Security. I recommended TLS_AES_128_GCM_SHA256 for most Web pages, TLS_AES_256_GCM_SHA384 for the confidential pages involving fiscal transactions, and TLS_CHACHA20_POLY1305_SHA256 for media streams. SingSnapĀ® did implement ECDHE_RSA_4096_SHA256 for all Pages /Karaoke/SingAndRecord/* and ECDHE_RSA_8192_SHA384 for all Pages /Karaoke/Store/* for handshake and authentication.

Marking in Favorites to track future Replies.

-Bev-LEVEL 102

Reply by -Bev-SPECIAL-EVENTS +1

Come and join the fun in the Singsnap Chorus forum/topic/b4196354

Well I am using a chrome book and I have managed to be able to use SS no problem...er so far....famous last words...lol

SunshineLEVEL 93

Reply by SunshineGOLD

Well I am using a chrome book and I have managed to be able to use SS no problem...er so far....famous last words...lol-Bev-

Hi Bev! It is not that I can't use it and record, it is just that I have to go through "hoops" to get a "connection" once I am in the recorder and I am thinking it has to do with Flashplayer and the "non secure" URL. Of course, I am in now a guru on this stuff, just trying to figure it out!

SunshineLEVEL 93

Reply by SunshineGOLD

Thank you all for your responses. I do get a secure "https" URL when I actually record a song. But I also get a statement asking me to update AdobeFlash every time I bring in a new song to record. And, I am currently running the latest update!

Just confused..... haha!

SunshineLEVEL 93

Reply by SunshineGOLD

UPDATE! Recorded a song just a few minutes ago and saved it. Tried to play it from my recordings page using Chrome and it won't play. Doesn't even show the recorder.....

Went to Microsoft Edge and recording played without any problems!

So I guess my question is now......are the problems with Chrome or a SS problem when using Chrome browser!

Thank you....

Bunnykins

Reply by BunnykinsGOLD +3

CHRISTMAS- watchandlisten/play?playlist_id=af10238a&start=9b1c6

UPDATE! Recorded a song just a few minutes ago and saved it. Tried to play it from my recordings page using Chrome and it won't play. Doesn't even show the recorder.....

Went to Microsoft Edge and recording played without any problems!

So I guess my question is now......are the problems with Chrome or a SS problem when using Chrome browser!

Thank you....Sunshine

Had the same issue for the last 3 days.....Recorder won't load at all using Chrome. I record on Edge with no problems but usually just use Chrome for listening. Not sure if Chrome or SS is the problem.

Bunnykins

Reply by BunnykinsGOLD +3

CHRISTMAS- watchandlisten/play?playlist_id=af10238a&start=9b1c6

Well I am using a chrome book and I have managed to be able to use SS no problem...er so far....famous last words...lol-Bev-

Hi Bev! It is not that I can't use it and record, it is just that I have to go through "hoops" to get a "connection" once I am in the recorder and I am thinking it has to do with Flashplayer and the "non secure" URL. Of course, I am in now a guru on this stuff, just trying to figure it out! Sunshine

At first it kept asking me to ALLOW FLASH but now the recorder won't show up at all.

Bunnykins

Reply by BunnykinsGOLD +3

CHRISTMAS- watchandlisten/play?playlist_id=af10238a&start=9b1c6

Just notice profile pics are blank too

SunshineLEVEL 93

Reply by SunshineGOLD

Thanks Bunny and sorry...sounds like you are having more problems than I am right now. I still get the box to allow flash player, but I can record..eventually!!

Seems we are having Chrome issues! Again or still!!

DevilsAdvocateLEVEL 3

Edited reply by DevilsAdvocate

The site doesn't show a 'lock icon' nor 'https' and the browser shows 'connection not secure'. I read it's secure in certain places here, but that's still not good enough in this day and age. Flash also needs to die on this site like yesterday with it's astonishing amount of security flaws. Hackers could have a field day here with all these vulnerabilities.